Blog

Written words that are often helpful

arXiv, Arch Linux, biblatex, biber

Posted by chathaway on Nov. 24, 2017, 5:30 p.m.

For the first time in years, an update was published to the biblatex package. This is quite exciting, but presents a problem for those of us who use "bleeding edge" software, like Arch Linux, and need to submit our papers to sites like arXiv, which use more stable packages. This is a quick work around.

The Problem

At the time of writing, there is a new version of biber and a new version of biblatex on my Arch system, which produces a .bbl file a version of "2.9". arXiv emits an error message, informing me that the bbl was expected to be version 2.8.

The Fix

Get an old version of biblatex, install it to ~/texmf

$ git clone https://github.com/plk/biblatex.git
cd biblatex
$ git checkout v3.7
Previous HEAD position was 78e9451a... Bug fixes
HEAD is now at d44a7a0f... Correcting test
$ obuild/build.sh install 3.7 ~/texmf
Created build trees ...
Installed TDS build tree ...
$ texhash ~/texmf/
texhash: Updating /home/chathaway/texmf//ls-R... 
texhash: Done.

# Expect the below as output; I left the long prompt
chathaway@blaze:~/programming/biblatex$ kpsewhich biblatex.sty
/home/chathaway/texmf/tex/latex/biblatex/biblatex.sty

Get an older version of biber

$ wget https://archive.archlinux.org/packages/b/biber/biber-2.7-3-any.pkg.tar.xz
$ sudo pacman -U biber-2.7-3-any.pkg.tar.xz

Compile the paper again

If you use git and didn't add the autogenerated gunk to your repo:

$ git clean -fd

Else, manually remove all files except the .tex, images, and other "human generated" files.

Compile the paper, and submit it

$ pdflatex main
$ biber main
$ pdflatex main
$ pdflatex main

Huzzah!


Banner Image © 2017 Ranjani Hathaway | Content © 2017 Charles Hathaway PDF